HeaderLogoFoot
Problem mit Wake on Lan vom Kontrollzentrum aus
captaindyck
#1 Geschrieben : Sonntag, 12. Januar 2014 14:47:22(UTC)

Rang: Member

Gruppe: Registered Users, Subscribers
Mitglied seit: 04.05.2010(UTC)
Beiträge: 29
Punkte: 87

Dankte: 2 mal
Hallo Jochen,

mein VCR.NET-Rechner lässt bzw. ließ sich öfters nicht über die Wake-On-Lan-Funktion im Kontrollzentrum von meinem Arbeitsrechner mit Win7 aufwecken. Mit einem einfachen Wake-on-Lan-Tool wie diesem reicht dagegen an der Kommandozeile ein "wol [MAC]" und der Server startet zuverlässig.

Ich konnte das Problem dahingehend eingrenzen, dass das Kontrollzentrum wohl an der Ermittlung der benötigten MAC-Adresse des aufzuweckenden VCR.NET-Rechners scheitert.

Wenn ich im Kontrollzentrum des Arbeitsrechners das Aufwecken anklicke, wird zuerst versucht, zum angegebenen Hostnamen des VCR.NET-Rechners die IP-Adresse zu ermitteln. Hier lauert die erste Falle, da Windows ziemlich schnell die Zuordnung von IPs und Hostnamen vergisst: "Unable to wake up server jan-videopc: Der angeforderte Name ist gültig, es wurden jedoch keine Daten des angeforderten Typs gefunden"
Allerdings scheint selbst die direkte Angabe der IP statt des Hostnamens nicht zuverlässig zu funktionieren: "Unable to wake up server 192.168.1.100: Der angegebene Host ist unbekannt"
Lösung ist ein manueller Eintrag in der Hosts-Datei von Windows. Danach funktioniert im Prinzip sowohl Hostname als auch IP.

Nach Umschiffen dieser Klippe, wartet leider sogleich die nächste Untiefe:
Anhand der IP versucht das Kontrollzentrum aus dem ARP-Cache die MAC-Adresse zu ermitteln, die für das Magic Packet benötigt wird. Leider gehen die Angaben der ARP-Tabelle ebenfalls leicht verloren, es reicht z.B., den Arbeitsrechner in den Ruhezustand zu schicken und wieder aufzuwecken. Der Befehl "arp -a -v" zeigt mir dann keine MAC-Adresse für die IP des Servers mehr an. Somit scheitert zwangsläufig der nächste Aufweckvorgang des VCR.NET-Rechners. Um dies zu umgehen ist ein weiterer statischer Eintrag, diesmal für die ARP-Tabelle notwendig. Mit "arp -s" funktioniert das anscheinend unter Windows 7 nicht mehr, sondern nur mit "netsh interface ipv4 add neighbors "Name der LAN-Verbindung" [IP] [MAC]"

Nach dem ich nun schließlich beide angesprochenen Maßnahmen durchgeführt habe, scheint das Aufwecken endlich zuverlässig zu klappen. Aber spätestens hier frage ich mich: Sind das nicht viel zu viele manuelle Eingriffe in das Windows-System, nur damit das Wake-on-Lan mit dem Kontrollzentrum klappt? Wieso kann ich nicht einfach die MAC-Adresse manuell im Kontrollzentrum konfigurieren?

Was die automatische Ermittlung der MAC angeht, ist der Haken wohl, dass das Kontrollzentrum dies erst dann versucht, wenn der anzusprechende Rechner aus ist und potentiell Windows keine Angaben über ihn mehr zwischengespeichert hat. Die Angaben müssten daher meiner Meinung nach vom Kontrollzentrum ermittelt werden, während der VCRNET-Server läuft (Status grün/gelb) und dann intern in der Konfiguration gespeichert werden, im Prinzip so, wie Du es auch mit der Broadcast-Adresse machst.

Gruß
Jan
JMS
#2 Geschrieben : Sonntag, 12. Januar 2014 17:59:09(UTC)

Rang: Advanced Member

Gruppe: JMS, Registered Users, Subscribers
Mitglied seit: 01.05.2010(UTC)
Beiträge: 396
Punkte: 1.191
Mann
Wohnort: Königswinter-Thomasberg

Es wurde: 5 mal in 5 Beiträgen gedankt
Ich hatte dazu auch schon einige Diskussionen mit mrth. Tatsache ist, dass man zum WOL die MAC braucht und alles, was Du beobachtest ist richtig. Ich habe hier das Problem lokal wohl nicht, da ich eine Fritz!Box als Router verwende, die äußerst hartnäckig Rechnername vs. IP vs. MAC merkt.

WOL ist ein Nebenschauplatz, in den ich nicht allzu viel Zeit investieren möchte, sehe aber Deine Bedenken mehr als ein. Daher folgender Kompromissvorschlag (vielleicht liest mrth ja mit): das Kontrollzentrum ermittelt "irgendwann" (muss ich klären) einmalig die MAC pro Eintrag und merkt sich diese. Die wird dann beim WOL verwendet, der Anwender muss nichts mehr tun. Wenn sich nun etwas verändert, esp. (aber nicht nur) die MAC wie bei mir, als vor Weihnachten die LAN Hardware auf dem Mainboard abgeraucht ist und ich eine neue LAN Karte brauchte, dann muss man halt den Eintrag im Kontrollzentrum entfernen und neu einrichten und das war es.

Wäre das akzeptable und würdet Ihr das testen wollen? Dann schaue ich nachher mal danach (muss noch gerade was beruflich machen).

Jochen
JMS
#3 Geschrieben : Sonntag, 12. Januar 2014 19:09:23(UTC)

Rang: Advanced Member

Gruppe: JMS, Registered Users, Subscribers
Mitglied seit: 01.05.2010(UTC)
Beiträge: 396
Punkte: 1.191
Mann
Wohnort: Königswinter-Thomasberg

Es wurde: 5 mal in 5 Beiträgen gedankt
Ich habe mal eine Variante gemacht, die wie beschrieben arbeitet. Die MAC wird einmalig ermittelt und dann in der Konfiguration abgelegt und beim neuen Starten wieder eingelesen. Ich habe den WOL Dialog auch so verändert, dass die MAC in Klammern angezeigt wird.

Falls es nicht mehr Beschwerden gibt würde ich von einem Patch für die 4.2 absehen und den Code in 4.3 belassen.

Jochen
Dateianhänge:
VCRNET Control Center.zip (37kb) 4x heruntergeladen.

Sie können diese Anhänge NICHT Ansehen/Herunterladen. Sie müssen Sich zunächst Registrieren.-
captaindyck
#4 Geschrieben : Sonntag, 12. Januar 2014 20:22:56(UTC)

Rang: Member

Gruppe: Registered Users, Subscribers
Mitglied seit: 04.05.2010(UTC)
Beiträge: 29
Punkte: 87

Dankte: 2 mal
Zitat von: JMS Go to Quoted Post
Die MAC wird einmalig ermittelt und dann in der Konfiguration abgelegt und beim neuen Starten wieder eingelesen.

Ja, so in der Art habe ich mir das auch vorgestellt.
Ich habe die Datei heruntergeladen und werde es ausprobieren.

Danke,
Jan
mrth
#5 Geschrieben : Montag, 13. Januar 2014 20:21:34(UTC)

Rang: Advanced Member

Gruppe: Member, Registered Users, Subscribers
Mitglied seit: 26.02.2011(UTC)
Beiträge: 152
Punkte: 456
Wohnort: Germany

Es wurde: 1 mal in 1 Beiträgen gedankt
Ich habe mir die Datei auch mal runtergeladen. Allerdings sehe ich nicht wo die ermittelte MAC Adresse stehen soll.
Eigentlich sieht alles wie vorher aus, nur das jetzt alles in Englisch ist.

Bei mir hat die alte Lösung zuverlässig funktioniert. Lag aber vielleicht daran, das ich die IP schon immer in der Hosts stehen hatte und zusätzlich die Broadcast Adresse des Subnetzes meiner LAN Karte angeben muss (mehrere Netzwerkkarten).

Helmuth
captaindyck
#6 Geschrieben : Montag, 13. Januar 2014 21:03:45(UTC)

Rang: Member

Gruppe: Registered Users, Subscribers
Mitglied seit: 04.05.2010(UTC)
Beiträge: 29
Punkte: 87

Dankte: 2 mal
Zitat von: mrth Go to Quoted Post
Allerdings sehe ich nicht wo die ermittelte MAC Adresse stehen soll.
Eigentlich sieht alles wie vorher aus, nur das jetzt alles in Englisch ist.

Nachdem Du auf "Wakeup Server" geklickt hast, wird die MAC-Adresse in dem Dialogfeld mit der Rückfrage, ob Du den Rechner wirklich aufwecken willst, angezeigt. Und nur dort. In der eigentlichen Konfigurationsübersicht steht sie nicht drin und ist auch dort nicht manuell veränderbar.

Die Oberfläche habe ich standardmäßig immer auf Englisch, kann sie aber auch mit der gepatchten Version wieder auf Deutsch setzen (nach Neustart des Kontrollzentrums). Die "VCRNET Control Center.resources.dll" muss natürlich in dem Unterverzeichnis "de" liegen.

Mein erster Eindruck - viel testen konnte ich nicht - ist jedenfalls, dass das Aufwecken bei mir nun auch ohne die händischen Eingriffe in die Windows-Systemkonfiguration klappt.

Gruß
Jan
mrth
#7 Geschrieben : Montag, 13. Januar 2014 22:46:10(UTC)

Rang: Advanced Member

Gruppe: Member, Registered Users, Subscribers
Mitglied seit: 26.02.2011(UTC)
Beiträge: 152
Punkte: 456
Wohnort: Germany

Es wurde: 1 mal in 1 Beiträgen gedankt
Nach dem Rechnerneustart ist die Oberfläche jetzt auch wieder in Deutsch. Da der Aufnahmerechner gerade an ist und was aufnimmt, kann ich das mit der MAC gerade nicht testen.

Helmuth
JMS
#8 Geschrieben : Montag, 13. Januar 2014 23:01:42(UTC)

Rang: Advanced Member

Gruppe: JMS, Registered Users, Subscribers
Mitglied seit: 01.05.2010(UTC)
Beiträge: 396
Punkte: 1.191
Mann
Wohnort: Königswinter-Thomasberg

Es wurde: 5 mal in 5 Beiträgen gedankt
Ich gebe ja zu, ich habe mir nicht allzu viel Mühe gegeben. Die MAC kann in der Tat weder angezeigt noch manuell angezeigt werden und erscheint NUR bei der Rückfrage zum WOL.

Das mit der Sprache ist mir nicht ganz klar, bei mir hat das geklappt, allerdings habe ich die auch fest auf Deutsch und ich habe das einfach in Tools überschrieben. Wo hast Du die EXE und CONFIG denn hin kopiert? Wenn nicht in Tools, dann muss man noch andere Dateien dazu kopieren (Newtonsoft und im de Unterverzeichnis die deutschen Texte).

Jochen
mrth
#9 Geschrieben : Dienstag, 14. Januar 2014 18:52:56(UTC)

Rang: Advanced Member

Gruppe: Member, Registered Users, Subscribers
Mitglied seit: 26.02.2011(UTC)
Beiträge: 152
Punkte: 456
Wohnort: Germany

Es wurde: 1 mal in 1 Beiträgen gedankt
War mein Fehler. Ich hatte die Dateien nach bin kopiert und beim ersten Mal auch dort gestartet. Nach dem Reboot wurden aber die alten Dateien aus Tools gestartet.
Jetzt passt aber alles und die MAC wird vor dem Aufwachen angezeigt.
JMS
#10 Geschrieben : Dienstag, 14. Januar 2014 18:59:27(UTC)

Rang: Advanced Member

Gruppe: JMS, Registered Users, Subscribers
Mitglied seit: 01.05.2010(UTC)
Beiträge: 396
Punkte: 1.191
Mann
Wohnort: Königswinter-Thomasberg

Es wurde: 5 mal in 5 Beiträgen gedankt
Sehr schön, vielen Dank für's Testen! Ich hab' Dein WOL Dokument immer noch nicht gelesen, weiß auch nicht, ob ich die Zeit dazu finde Scared

Tschüss

Jochen
Rss Feed  Atom Feed
Benutzer, die gerade dieses Thema lesen
Guest (16)
Das Forum wechseln  
Du kannst keine neue Themen in diesem Forum eröffnen.
Du kannst keine Antworten zu Themen in diesem Forum erstellen.
Du darfst deine Beiträge nicht löschen.
Du darfst deine Beiträge nicht editieren.
Du kannst keine Umfragen in diesem Forum erstellen.
Du kannst nicht an Umfragen teilnehmen.